Author Topic: Crash using peculiar nodes and properties (1.10.5 Pro)  (Read 50 times)

Rodolfo Calabrezi

  • Jr. Member
  • **
  • Posts: 8
  • INSANE Games Sr. Technical Artist
Hey there!

I've got a peculiar situation here. Take a look at the attached image. What could go wrong, right?

Don't ask me how I got there, but here it goes:

  • Open Instant Terra (1.10.5 Pro). It will open a new project and the standard 3 nodes graph
  • Delete all those nodes related to the new project (*)
  • Create the nodes exactly as the attached image suggests, keeping their default properties
  • In the "Mask from heights" node (highlighted in the image):
    4.1. Change "Heights" to "Manual"
    4.2. Change "Minimum height" to "50"
  • Now save the project (just to get you in the crash trigger)
  • Open it again (important)
  • And for the crash to happen, in the "Blend" node (highlighted in the image):
    7.1. Change "Blend mode" to "Max" or "Min"
(*) Is it possible to create an empty project?

I'm attaching the referred image above as well as steps 1-5 saved in a project, just in case.

Hope you find what is behind this crash faster than I was able to find what is causing it. :0)

Thanks!

Alexis Vaisse

  • Administrator
  • *****
  • Posts: 102
Hi Rodolfo,

Thank you very much for your detailed and precise description.

We've been able to reproduce and fix the crash. The fix will be in Instant Terra 1.11.

Just for your information, a lot of conditions had to be met in order to reproduce the crash:
- A Blend mode with "Min" or "Max" mode.
- A totally black mask (that's why you had to switch from "Automatic" to "Manual" mode for the Mask from heights node).
- Two terrains with the same size (no crash if the two terrains of the Blend mode don't have the same size).
- No tiling.
- Directly select the Blend mode after the project is open (that's why you had to save and open the project).

Thanks again you for your help.

Rodolfo Calabrezi

  • Jr. Member
  • **
  • Posts: 8
  • INSANE Games Sr. Technical Artist
Hey Alexis! Thank you for your quick response!

In order for you to repro the issue, these conditions have to be met, yes. But have in mind this report scenario is hypothetical. I have a more complex and functional project that is crashing randomly and I spent some time on it trying to isolate the problem at this simplicity. So for instance this project sometimes crashes just creating a new node.

So I guess there are yet other conditions to be investigated, e.g., if you create these nodes from scratch and save the project with the Blend mode already set to "Min" or "Max", at first glance it won't crash. But if you open that project, it will crash right away. Or if you use a "Mask from heights" node with "Minimum height" set to "0", it won't crash. Any terrain connection with a "Perlin noise" will crash, but other noises won't. And so on.

Happy to know that I could help!