Author Topic: Crash when setting component to "Internal" category.  (Read 134 times)

Flint Stryker

  • Jr. Member
  • **
  • Posts: 14
Using version 1.15. Crash occurs when attempting to set the category of a component to "Internal". No special conditions that I've found; this happens in all situations.

Edit: This also happens when trying to save one or more nodes as a component in the "Custom Nodes" category.
« Last Edit: December 29, 2020, 04:33:13 PM by seversky »

Alexis Vaisse

  • Administrator
  • *****
  • Posts: 138
Hi,

Thank you very much for reporting this crash.
We will fix it for the next release of Instant Terra.

Flint Stryker

  • Jr. Member
  • **
  • Posts: 14
Thank you. Followup question: what is the purpose of the "Internal" category? I was hoping that it would enable me to create a component that is internal to a component; in other words, a child component that only the parent component has access to. Is that what this is for?

Alexis Vaisse

  • Administrator
  • *****
  • Posts: 138
Actually the "Internal" category was not supposed to be visible. ;-)
It's used only by the dev team for debugging purpose.
It won't be visible anymore in the next release of Instant Terra.

You can create your own categories. They will be added automatically in the Models window.

It's possible to create a component containing another component.
The limitation is a component has to be created in the main graph.
So you can create a first component A. Create a graph with one or several A nodes, then create another component B from them.

But there is no way to tell Instant Terra that a component can only be used inside a component and not in the main graph.

Flint Stryker

  • Jr. Member
  • **
  • Posts: 14
Thanks! Unfortunate that all components are part of the main graph. Some of my components were created just to repeat processes within a component, and make no sense on their own. No harm there, of course, but it feels messy.