Author Topic: Crash on Startup with Requirements Installed  (Read 450 times)

Rylan

  • New Member
  • *
  • Posts: 2
Hello.  I decided to try Instant Terra based on a recommendation that it could help me achieve a particular task.  I downloaded and installed the trial as well as the two main requirements listed on the main site and in this forum (Visual studio and .NET)

When I try to launch the program, the splash screen comes up, remains for about 15 seconds, and then I get a small error message box with a generic error in broken english:

Error
A crash has occured.
It has been sent.


Another user encountered the same issue and posted on the forum here: https://www.wysilab.com/forum/index.php?topic=76.0 but didn't provide a solution or any further information.

There is another post with the same error here: https://www.wysilab.com/forum/index.php?topic=229.0


I have tried reinstalling Instant Terra, and both of the requirements.  I have also tried the solutions in this topic: https://www.wysilab.com/forum/index.php?topic=22.0


So far, no luck.  I'm on Windows 7 Professional 64 bit


Could anyone help me find a solution?  If other users managed to figure it out, could you share the info publicly here?

Alexis Vaisse

  • Administrator
  • *****
  • Posts: 187
Hi,

We received some anonymous crash reports, I guess they come from your computer.
The error message is "Font 'Arial' does not support style 'Regular'".
It seems that you have an error with your Windows fonts. The Arial font seems to be corrupted.
Reinstalling the Arial font may fix the problem.

Here are some links to pages describing a similar problem:
- https://answers.microsoft.com/en-us/windows/forum/windows_7-performance/message-font-arial-does-not-support-style-regular/3d7099fc-3081-4408-ad76-4f79045f9ee1
- https://www.andica.com/faq-font-arial-does-not-support-style-regular.html
- https://www.ibm.com/support/pages/font-arial-does-not-support-style-regular

Please let us know if it doesn't help.

Rylan

  • New Member
  • *
  • Posts: 2
That seems like it actually was the issue.

Somehow my fonts got slightly messed up a while back and I never got around to fully fixing them until like a week ago.  I thought I had caught everything and nothing reported any font errors or issues so I thought it was good.  This is especially weird to me considering Arial is a pretty commonly used font and it has consistently displayed just fine this whole time.

I had to download a copy from a different website since the Microsoft links don't actually have downloads anymore but upon installing the font Instant Terra launched without issue.  What and odd and obscure issue.

I can't help but wonder if this is something I could have diagnosed myself.  Does instant terra produce error logs for launch errors?

Alexis Vaisse

  • Administrator
  • *****
  • Posts: 187
I'm glad it fixed your issue.

When a recoverable error happens, Instant Terra can display an error message.
But when the error is not recoverable, the error message is most of time obscure, such as "Attempted to read or write protected memory" or "External component has thrown an exception", followed by some crypted information which is totally unusable when you don't have the tool to decrypt it. In this case, there's no useful error message that Instant Terra can display.