Author Topic: Generation is too slow in real usecases  (Read 260 times)

Cryunreal

  • Sr. Member
  • ****
  • Posts: 55
Generation is too slow in real usecases.

I dont use any simulation effects, but i use GPU script and several subgraphs (components).

Even after 20 minutes the single mask was not generated. I see only infinite streaming in viewport and never see the final result.

I will send you my graph with my custom components.

Try to generate and export the mask, this is just a 16k.


if you need any help to test your software i can try to help you, and i hope you want it too.

Right now your software almost does not work in real cases.
« Last Edit: June 29, 2021, 06:17:10 PM by Cryunreal »

Alexis Vaisse

  • Administrator
  • *****
  • Posts: 187
If you use large terrains and a graph with a lot of nodes, Instant Terra may require a substantial amount of memory to be able to compute everything.
If you count the number of nodes inside the graph plus the nodes inside component nodes and nodes inside component nodes that are themselves inside other component nodes, you have more than 300 nodes.
For 16K x 16K terrains, Instant Terra may require 64 GB of RAM or more.

One possible solution is to split your project into several smaller projects.
One project can export a terrain and another project can import it.
Or several projects can generate different parts of the terrain and another project can do the final compositing.

If you use Instant Terra Pro, you can also add some "Save point" nodes in your graph. Each "Save point" node stores its input in a cache on hard drive (SSD recommanded for better performance). When you open your project, if you don't modify the nodes before the "Save point" node, the "Save point" node will read the terrain from the cache instead of computing the nodes before it.

Cryunreal

  • Sr. Member
  • ****
  • Posts: 55
Generation was finished, but i took 6:36 hours.
Sometimes this graph works very fast (around several minutes), but sometimes very long (several hours).

I am sure there are bugs. 
Pls open this graph and try to export, this graph pretty simple.

After export i dont know how long was generated every node, this is big trouble. I dont know what exactly nodes i should optimize.

Displaying of last generation time for every single node in graph explorer and in export window will be superior to help us. Right now i dont even know speed of nodes.

Cryunreal

  • Sr. Member
  • ****
  • Posts: 55
My pc:

rtx 2070 super
32gb ram
Ryzen 7 3800x
ssd 1tb


Cryunreal

  • Sr. Member
  • ****
  • Posts: 55
I changed resolution from 16384 to 8192 and now my generation is around 10 - 20 seconds.

6 hours vs 10 seconds.

definitely something is wrong.